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1. INTRODUCTION 

Geographic Information System (GIS) is defined as a computer-based information 
system that enables captures, modeling, manipulating, retrieval, analysis and 
presentation of geographically referenced data. It is a compound of digital maps and 
data base tables, which represent the real world.  
GIS established to help Decision Makers & Developers to find solutions for different 
tasks.   

ArcView 3.2 
ArcView is a software application, which give you the ability to create your own GIS and 
mapping the geographical data.  
As you start working with ArcView you create a Project. An ArcView project is one file 
that contains the views, tables, charts, layouts, and scripts that appear on your screen 
(see the Arcview Interface on the next page). It also records all steps you have done 
during your work. 

Raster and Vector data 
Raster data: is Digital data representing feature in cell such as any Images. 
Vector data: is Digital data representing feature in node and vertex. 

2. CREATING A PROJECT 

Start ArcView application from:  
Start \Programs\Esri\ArcView GIS 3.2\ArcView GIS 3.2 (ArcView window will open with 
the following options box) 
 
 
 
 
 
 
 
 
 
 

 
 
 

 
 

- Click OK  (to Create new untitled project with view) 
 
Add new view
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- Activate the project window 
- click on the view icon 
- click new (a new view is added to the project) 

3. SET VIEW PROPERTIES 

- From view Menu Click → Properties 
- Click Map Units box and change to ……… Meter 
- Click Distance Units box and change to…. Meter 
- Click OK. 

4. ADD AN IMAGE TO VIEW 

 Add the Image Extensions 
- From File Menu Click Extensions… 
- Click check boxes of (IMAGINE Image Support - JPEG – NITF- MrSID –TIFF 

6.0) 
- Click OK 

Add Images 
- From View Menu Click Add Theme 
- Click Data Source Type and select Image Data Source 
- Browse to Image folder (Select files with *.img or *.Tif)  
- Click OK   
- The Image will be added to View. 

You can load more than one image if you hold down the Shift Key and Click on the 
Image. 

Display the Image or Shape file in View 
- In View click the check box close to the file name  

5. WORKING WITH GRAPHICS    

On the following pages you’ll find the most important features of working with graphics 
explained:  

- graphic types 
- selecting a graphic 
- resizing a graphic 
- group and ungroup graphics 
- moving a graphic 
- changing graphic properties 
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Graphic types 
The drawing tools let you draw the following types of graphics on your view or layout:  

 
Points 
Straight lines 
Line with two or more points 
Rectangles 
Circles 
Polygons 
 

The text tool  lets you draw text on your view or layout. 
The frame tools let you draw the following graphics on your layout:  
  
 
 
 
 
 
 
 
 

Selecting a graphic 

When you select a graphic with the  tool, ArcView brackets the graphic with 
handles. In most cases, eight handles appear for a graphic, one at each corner and one 
at each edge of the graphic's bounding box. 
There are two selection methods: point and box.  
To select at a single point 
> Click on it. This will select the top-most graphic at the location you clicked. 
To select using a box 
> You can click-drag a box to select all the graphics that fall entirely within the selection 
rectangle. 
 
Note   Normally, when you select a graphic, any currently selected graphics will become 
unselected. If you hold down the SHIFT key, each additional selection you make will be 
added to the previous selection.  

 

 

ViewFrame - Show a View document 

 LegendFrame - Show a Legend for a ViewFrame 

 ScaleBarFrame - Show a Scale bar for a ViewFrame 

 NorthArrow - Show a North Arrow 

 ChartFrame - Show a Chart document 

 TableFrame - Show a Table documemt 

 PictureFrame - Import graphics from another file. 
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To group and ungroup graphics 
You may want to group several graphics so that their relative positions will not be lost 
when you move them, especially after you have aligned them.  

- To group graphics: 

1   Use the  tool to select the graphics you want to group. 

2   Either click the  button or choose Group from the Graphics menu.  
Once grouped, you can change the properties of all graphics, i.e., font, color, outline, 
etc. However, you cannot change the properties of individual graphics in a group, for 
example, you can't change the color of a single graphic. Therefore, it is necessary to 
Ungroup your graphics. 

To ungroup graphics: 

1   Use the  tool to select the graphic group(s) you want to ungroup 

2   Either click the  button or choose Ungroup from the Graphics menu.  

Resizing a graphic 
When you select a graphic you can resize it in two ways: interactively with the mouse or 
using the Size and Position choice from the Graphics menu.  

- Resizing with the mouse 
You can resize a graphic with the mouse by positioning the mouse on a handle and 
dragging. The corner handles provide stretching that will maintain the aspect ratio (i.e. if 
you stretch a square from one of its corner handles it will st ill be a square when you are 
done). The side handles allow you to resize in the horizontal or vertical directions. A 
faint outline of the graphic being stretched follows the mouse movement, and the 
graphic is redrawn when the mouse button is released. 

- Resizing with the Size and Position choice from the Graphics menu 
If you choose to resize the graphic in a more precise manner you can use the Size and 
Position choice from the Graphics menu. This will present a dialog box that allows you 
to define an exact size and position for the graphic. 

Moving a graphic 
When you select a graphic you can move it in two ways: interactively with the mouse, 
and using the Size and Position choice from the Graphics menu.  On the layout, you 
can also move a graphic using the keyboard arrow keys. 

- Moving with the mouse 
To move a graphic, press and hold the mouse button within a selected graphic or 
graphics, then drag to a new location. A faint outline of the selection follows the mouse 
movement; the graphic re-draws in the new location once the mouse button is released.  

PDF created with FinePrint pdfFactory trial version http://www.pdffactory.com

http://www.pdffactory.com


 6

- Moving with the Size and Position choice from the Graphics menu 
To move a graphic to an explicit location, you can use the Size and Position control 
from the Graphics menu. This creates a dialog box in which you can type the position of 
the graphic in page units. 

- Moving with arrow keys 
To move a layout graphic in increments, you can use the arrow keys on the keyboard to 
"nudge" the graphic.  Each arrow keystroke moves the graphic one point (1/72 of an 
inch). 

Changing graphic properties 
The properties, or symbol, of a graphic differ depending on the type of graphic. You can 

change the properties of a graphic by using the Pointer tool  and double-clicking on 
it. 

Polygonal graphics 
Polygonal graphics can be filled (i.e. rectangles, circles, etc.). You can change the 
following properties for polygonal graphics: 

- Foreground fill (transparent, opaque, or pattern) and color 
- Background fill (transparent, opaque, or pattern) and color 
- Thickness and color of the outline 

Line graphics 
You can change the following properties for line graphics: 

-  Line type (pattern) 
-  Thickness 
-  Cap (butt, round, or square) 
-  Join (miter, round, or square) 
-  Foreground color 

Point graphics 
-  Pattern 
-  Foreground color 
-  Size (Diameter) 

Text graphics 
You can change the following properties for text graphics: 

-  Font 
-  Size 
-  Style (normal, bold, italic, bold-italic) 
-  Color 
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6. SAVE PROJECT    

- From the File menu, choose Save Project. 
- Navigate to the folder and Type the name  
- Click ok to save the project.  

Remember always to save your project 

7. MANAGE DATA SOURCES 

Allows you to delete, copy, and rename data sources such as shapefiles, grids, and 
TINs. Make sure you use this utility to perform these tasks - don't use your computer's 
file system commands – because each of these data sources is made up of multiple 
files. By default, Manage Data Sources lets you delete, copy, and rename shapefiles. 
Choose a data source from the list on the left, then click the button for the action you 
wish to perform. 

- From File Menu Click “Manage Data Sources” 
- After you finish Click cancel 

Copy  
You'll be prompted to enter the new name and location for the copy of the data source. 

Rename 
You'll be prompted to enter the new name for the data source. 

Delete  
You'll be prompted to see if you really want to delete the data source. 

8. WORKING WITH VIEW 

Create new View 
- Click on the Project window 
- Click on Views Icon 
- Click New  
- The new View will be created and you have to set its properties again. 

Zooming in View    
See attached doc (ArcView 3.2 Interface) 

9. WORKING WITH SHAPE FILES 

Shape file is the format of the vector data that you product by ArcView. Normally one 
shape file contain of three files carrying the following formats: 
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Create new shape file 
- From View Menu Click New Theme 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

- From feature type select (Polygon, Line or Point) 
- Click OK.       
- The new theme box will be opened. Navigate to your folder and in the File Name 

type a name of your file. 
- Click OK.      
- the new theme will added to View. 

Set theme Properties (snap) 
- From Theme Menu Click Properties 
- The theme properties box will opened 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

- Click on Editing Icon 
- In Snapping panel Click General Check box and Type a tolerance value into the 

tolerance field. 
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- In Snapping panel Click Interactive Check box and Type a tolerance value into 
the tolerance field. Press OK. 

General Snapping 
If you want your features to be automatically snapped to other features within the 
specified tolerance, set ArcView’s general snapping environment. General snapping is 
feature-to-feature snapping that gets applied as soon as you have added a new feature.  

Interactive snapping 
For better control over how your features get snapped, use interactive snapping. With 
interactive snapping, you can apply different snapping rules on a per vertex basis while 
you are adding a new line or polygon feature. In this way, you will be able to control how 
each vertex along the line or polygon boundary you are adding is snapped to existing 
lines or polygons in the theme.  

10. CREATING POLYGON FEATURES 

Before you start creating polygons, decide whether they should be perfectly aligned. If 
it’s important not to have gaps or overlap, you should set the snapping environment. If 
you create a polygon near another polygon that’s within the snap tolerance, this new 
polygon will get snapped to the other polygon, eliminating gaps and overlap.  

To create an irregularly shaped polygon feature 
1 If the theme is not already in edit mode, make the theme active and from the Theme 

menu, choose Start Editing. 

2 Click the Drawing tool palette  and in the list of tools that pops down, click the 

Polygon tool . 
3 In the view, click the left mouse button  where you want the polygon to start, click  each 

vertex around the polygon’s boundary, then double-click the final vertex. 
 
If you have set the interactive snap environment, then while you are adding your 
polygon, you can hold down the right mouse button to display the popup menu, and 
choose one of the snapping options from this menu to control how the next vertex  you 
add  to the boundary will be snapped to existing polygons in the theme.  
 
When you create a new polygon feature in the theme, a corresponding new record is 
automatically added to the theme’s feature attribute table. While you are editing a 
theme, its table is also in edit mode. You can add data for this record at anytime by 
entering new values in the table. 
 
Note  While you are creating a line, you can choose the Delete Last Point optio n from 
the popup menu to delete the last vertex you added. Choosing this option repeatedly 
enables you to successively delete all the vertices back to the start point of the line.  
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To create a circular polygon feature 

1 Click the Drawing tool palette  and in the list of tools that pops down, click the 

Circle tool . 
2 In the view, position the cursor where you want the center of the circle to be, hold 

down the left mouse button and drag the mouse until the circle is the s ize you want, 
then release the mouse button.  

To create a rectangular polygon feature 

1 Click the Drawing tool palette  and in the list of tools that pops down, click the 

Rectangle tool . 
2 In the view, position the cursor where you want the corner of the rectangle to be, hold 

down the left mouse button and drag the mouse until the rectangle is the size you 
want, then release the mouse button.  

To create a polygon that shares its boundary with existing polygons 

You can use the AutoComplete tool  to create a new polygon if it shares part of its 
boundary with an existing polygon(s) in your theme. In this way, it's not necessary to 
redraw the portion of the polygon's boundary that is already represented in your theme.  

1 Click the Drawing tool palette  and in the list of tools that pops down, click the 

AutoComplete tool .  
2 Draw a line that starts and stops at any of the existing polygon boundaries to enclose 

the area of the new polygon you are creating. To draw the line, click where you want 
the line to start, click each vertex along the line, then double-click the final vertex. 
When you draw the line, you can overshoot the existing polygon boundaries.  

 
When you have finished drawing the line, ArcView automatically completes the new 
polygon, and removes any overshoots from the line you drew.  

  
 
Note A shapefile can only contain one feature type so polygon features can only be 
added to themes based on polygon shapefiles. 

11. CREATING LINE FEATURES 

Before you add line features to your line theme, decide whether they should meet and 
align perfectly. If it’s important for all lines coming together at an intersection to share 
the same endpoint, and for there to be no overshoots or undershoots, then you should 
set the snapping environment. When you use snapping, ArcView moves the vertices or 
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line segments of new features you add to align with the vertices or line segments of 
other features that are within a specif ied distance, the snap tolerance. 

To create a line feature in a line theme 
1 If the theme is not already in edit mode, make the theme active and from the Theme 

menu, choose Start Editing. 

2 Click the Drawing tool palette  and in the list of tools that pops down, click the Line 

tool . 
3 In the view, click the left mouse button where you want the line to start, click each 

vertex, then double-click the final vertex. 
 
If you have set the interactive snap environment, then while you are adding your line, 
you can hold down the right mouse button to display the popup menu, and choose one 
of the snapping options from this menu to control how the next vertex you add to the 
line will be snapped to existing lines in the theme. 
When you create a new line feature in the theme, a corresponding new record is 
automatically added to the theme ’s feature attribute table. While you are editing a 
theme, its table is also in edit mode. You can add data for this record at anytime by 
entering new values in the table. 
 
Note  While you are creating a line, you can choose the Delete Last Point option from 
the popup menu to delete the last vertex you added. Choosing this option repeatedly 
enables you to successively delete all the vertices back to the start point of the line. 

To create a line feature that splits other lines it crosses 
In your line theme you may need to draw a new line that crosses an existing line and it 
may be necessary for the two lines to be split where they cross so that an inters ection is 
created, otherwise the new line would represent an overpass. In ArcView, you can use 

the Line Split tool  to create a line that gets split wherever it crosses another line, 
and also splits all lines it crosses.  

1 Click the Drawing tool palette  and in the list of tools that pops down, click the Line 

Split tool . 
2 In the view, click the left mouse button where you want the line to start, click each 

vertex, then double-click the final vertex. The line you draw with the Line Split tool 
must cross over at least one other line for any new features to be created. Both the 
existing line and the new line are split into two separate lines at the point where they 
cross. 

Note A shapefile can only contain one feature type so line features can only be added 
to themes based on line shapefiles. 
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12. CREATING POINT FEATURES 

To create point features in a point theme 
1 If the theme is not already in edit mode, make the theme active and from the Theme 

menu, choose Start Editing. 
2 Click the Drawing tool palette and in the list of tools that pops down, click the 

Point tool  
3 Click the left mouse button in the view to add points.  
 
When you create a new point feature in the theme,  a corresponding new record is 
automatically added to the theme ’s feature attribute table. While you are editing a 
theme, its table is also in edit mode. You can add data for this record at anytime by 
entering new values in the table. 
Note A shapefile can only contain one feature type so point features can only be added 
to themes based on point shapefiles. 

13. RESHAPING POLYGONS 

You can use the Vertex Edit tool  to reshape a polygon by moving, adding, or 
deleting vertices. When you edit a polygon, you can choose to preserve topology, or 
not, by the way in which you select the feature:  
> When you select a single polygon, any edits you make to the vertices will affect only 

that polygon.  
> When you select a shared boundary between two polygons, any edits you make to the 

vertices will affect both polygons.  
> When you select a node common to two or more polygons, any edits to that node will 

affect all the polygons that contain that node. 
 
- To move a vertex with the Vertex Edit tool 
Place the cursor on the vertex you want to move. When the cursor appears as a 
crosshair, hold down the left mouse button and drag the vertex to the new position.  
 
- To add a new vertex with the Vertex Edit tool  
Move the cursor to the position on the line where you want  the new vertex. When the 
cursor appears as a target, click the left mouse button.  
 
- To delete a vertex with the Vertex Edit tool 
Place the cursor on the vertex you want to delete. When the cursor appears as a 
crosshair, press the DELETE key on the keyboard. 

To reshape a single polygon 

1 Click the Vertex Edit tool . 
2 Click inside the polygon. A hollow, square vertex handle appears at each vertex of the 

polygon's boundary.  
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3 Now when you move, add or delete vertices, only the single polygon will change. 

 

To reshape a common boundary between two polygons  

1 Click the Vertex Edit tool . 
2 Click on the common boundary. Square vertex handles will appear at each vertex of 

the shared boundary and round anchors will appear at the vertices at each end of the 
common boundary.  

3 Now when you move, add or delete a vertex, both polygons will change.  

 

To move a node that is common to a number of polygons  

1 Click the Vertex Edit tool . 
2 Click on the node that is common to two or more polygon features. A square vertex 

handle will appear at this node, and round anchors will appear on the next closest 
vertex on each polygon. 

3 Now when you move the common node, all polygons, which  share this node, will 
change. 

 

Splitting polygon features 

When you are editing polygons, you can use the Polygon Split tool  to draw a line 
across a polygon to split it into separate polygons. For example, to create 10 adjacent 
land parcels, you can create one polygon that represents the outer boundary of all the 
parcels, and then use the Polygon Split tool to draw the boundary lines between them to 
split the polygon into 10 separate polygons. This capability also makes it easy to modify 
existing polygons. For example, to make a polygon smaller you can use the Polygon 
Split tool to simply split off the unwanted part, select it, and then delete it.  
 
- To split polygon features: 
1 If the theme is not already in edit mode, make the theme active and from the Theme 

menu, choose Start Editing. 
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2 Click the Drawing tool palette  and in the list of tools that pops down, click the 

Polygon Split tool . (If this tool is dimmed out, your theme is not currently in edit 
mode. Choose Start Editing from the Theme menu).  

3 Draw a line across the polygon you want to split. To draw the line, click where you 
want the line to start, click each vertex along the line, then double-click the final vertex. 
You can overshoot the boundary of the polygon you are splitting. (The same line can 
continue through more than one polygon if you want to split a number of polygons at 
once).  

 
When you have finished drawing the line, ArcView automatically splits the polygon 
along the line you drew, and removes any overshoots from the line.  

When a feature is split with the Polygon Split tool , the record of that feature is 
removed from the theme’s feature attribute table and two new records are added to the 
table to represent the new features. If you want to specify how the data in the original 
record is handled when you split polygon features, you can set attribute update rules for 
each field in the table. 

Merging polygons 
If you have a group of polygons that you want to merge into one polygon, use the Union 
Features option. Union Features returns the union of the selected features to create a 
single feature. If the selected polygons share a common boundary, the common 
boundary is removed to create a single polygon. If the selected polygons overlap, the 
boundaries of the overlap are removed to create one polygon. If the polygons are not 
adjacent or overlapping, the result is one feature with multiple parts.  
 
- To merge polygons: 
1 If the theme is not already in edit mode, make the theme active and from the Theme 

menu, choose Start Editing. 
2 Use the Pointer tool  to select the polygons you want to merge.  
3 From the Edit menu, choose Union Features.  
 
When a set of features is merged with the Union Features option, the records of those 
features are removed from the theme ’s feature attribute table and one new record is 
added to the table to represent the new feature. If you want to specify how the data in 
the original records is handled when you merge polygon features, you can set attribute 
update rules for each field in the table. 

Obtaining the intersection of polygons 
Use the Intersect Features option if your theme contains several polygons that overlap 
and you are only interested in the area that is shared by the overlapping polygons. This 
creates a new polygon from the area common to the overlapping polygons, and 
removes all the original polygons. 
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- To obtain the intersection between polygons:  
1 If the theme is not already in edit mode, make the theme active and from the Theme 

menu, choose Start Editing. 
2 Use the Pointer tool   to select the polygons you want find the intersection of. In 

this example, two polygons have been selected. 
3 From the Edit menu choose Intersect Features. 

Removing area of overlap between polygons 
If you have two overlapping polygons and want to remove the area of overlap, you can 
subtract one polygon from the other using the Subtract Features option. The polygon on 
top gets subtracted from the polygon on the bottom, so the portion of the bottom 
polygon that is overlapped by the top polygon is removed, and the top polygon remains 
unchanged. 
Suppose you are adding a new polygon to your theme and one of the existing polygons 
extends into the area where the new polygon should be. You can draw the new 
polygon, extending on top of the existing polygon, and then use Subtract Features to 
remove the area of overlap from the existing polygon.   
 
- To remove area of area of overlap between polygons:  
1 If the theme is not already in edit mode, make the theme active and from the Theme 

menu, choose Start Editing. 
2 Draw the new polygon, partly overlapping an existing polygon. 
3 Use the Pointer tool  to select the new polygon and the existing polygon 

containing the area you want to subtract. (Subtract Features only works on two 
selected polygons at a time). 

4 From the Edit menu choose Subtract Features.  
 
Note If you want to reverse the order of the operation, that is, subtract the bottom 
feature from the top feature, hold down the SHIFT key as you choose Subtract Features 
from the menu. 
 
You can also use the Subtract Features option to create an island polygon (a polygon 
that is totally surrounded by another polygon but which doesn't overlap the po lygon it is 
surrounded by). To create an island polygon, draw the polygon on top of the polygon 
that it is surrounded by, select both polygons, and choose Subtract Features.  

14. MOVING FEATURES 
- To move features with the mouse:  
1 If the theme is not already in edit mode, make the theme active and from the Theme 

menu, choose Start Editing. 
2 Use the Pointer tool  to select the feature or features you want to move.  
3 Press and hold the mouse button within a selected feature or features, then drag to a 

new location. A faint outline of the selection follows the mouse movement; the feature 
re-draws in the new location once the mouse button is released.  
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15. DELETING FEATURES 
- To delete features: 
1 If the theme is not already in edit mode, make the theme active and from the Theme 

menu, choose Start Editing. 

2 Use the Pointer tool  to select the feature or features you want to delete.  
3 Press the DELETE key. 
 
The features are removed from the theme, and the corresponding records in th e 
feature attribute table are automatically removed.  
 
See also 
Selecting features for editing 
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16. CREATING A NEW TABLE 

You may want to create a new table in ArcView and then add data to it. 
To create a new table in your project: 

- From the Project window, select the Tables icon and then press the New button 
- enter a name and a disk location for the dBASE file that ArcView will create to 

store the source data for the table. A new table will appear in your project. 
ArcView names new tables in numerical order: Table1, Table2, Table3, etc. See 
Working with tables in a project. 

Add fields to the table 
- From Edit menu the Table menu bar, Click Add Field. The Field Definition dialog 

box will appear. 
  

 
- in the name type the field name you want 
- From type select the data type you will enter 
- Select numbers if you will enter only numbers data 
- Select string if you will enter text data 
- Click OK (the new field will added to the table by the same way you can many 

fields as you want) 

Add records to the table 
- From the Edit menu, Click  the Add Record. This will add a single record to the 

table. Repeat this action as many times as needed. 

Add data to the table 
- On the Table tool bar, select the Edit tool. This allows you to edit the empty cells 

in the table. See Editing the values in a table. 
- NOTE:  Spaces, periods and other non-alphanumeric characters in file or 

directory names may cause problems. Spaces and underscores are the only 
non-alphanumeric characters that should be used. It is also recommended that 
you follow an 8.3 naming convention. 

Edit values in a table 
Only tables based on dBASE or INFO files on disk can be edited.  
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To edit the values in a table: 
- From the Table menu, Choose Start Editing. 
- Select the Edit tool and place the cursor in the field of the record you want to edit. 

Type the new value into the field. When using the Edit tool in the table, the 
following keyboard accelerators are supported for the editable cell: 

 
  TAB   Moves to the cell to the right 
  SHIFT-TAB   Moves to the cell to the left 
  RETURN   Moves down a cell 
  SHIFT-RETURN   Moves up a cell 
 
To finish editing and commit your changes: 

-  Choose Stop Editing from the Table menu. 
 
You cannot edit tables which data source is a delimited text file or the result of a SQL 
query to a database. To edit data in these tables you should first export them to dBASE 
or INFO format and then add them back into your project. 
You can only edit the values of fields in the destination table if the active table is 
composed of one or more joined tables. See Joining tables. 
 
Note: If you have write access to the source data for your table, and if the source data is 
in INFO or dBase format, you can perform editing tasks on the table in ArcView.  

Make a table editable 
- Choose Start Editing from the Table’s Table menu. The names of fields in the 

table that you can edit appear in normal font. The fields that you cannot edit are 
shown in italics. 

Undo and redo edits 
- Choose Undo Edit from the Edit menu to undo the last edit to the table.  

Choosing this option repeatedly enables you to successively undo all the edits you 
made to the table since you started editing. This option does not undo the addition or 
deletion of a field.  
The Redo Edit option allows you to re-apply the last edit that was undone. Choosing this 
option repeatedly enables you to successively redo all the edits you undid since you 
started editing. 

17.  SAVE EDITS 

Save edits and continue editing 
- Choose Save Edits from the Table menu to save all edits made to the table 

during the current edit session.  
Once you save the edits, you can continue to edit the table but you are not able to undo 
or redo any edits that were made prior to choosing Save Edits. 
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Save edits into a new table 
- Choose Save Edits as from the Table menu to save your edits out to a new file 

rather than changing the original file.  
The edited version of the original table will be written out to the new dBase file. Editing 
will be disabled on the original table and the edits will not be written to the original file. 
The new file will be opened as a new table and editing will start on the new table 
automatically. 

Stop editing and commit your edits 
- Choose Stop Editing from the Table menu to disable editing on the table.  

You will be prompted to save your edits. 
 
See Also 

• Adding and deleting fields in a table 
• Adding and deleting records in a table 
• Editing the values in a table 
• Calculating field values 

18.  SELECT A TABLE FROM THE PROJECT WINDOW 

An ArcView project can contain a number of tables. 
To see which tables are in a project: 

- Click on the Tables icon in the Project window.  
The tables in the project are shown in the list. 

Open a table 
- double click the table's name in the list of tables in the Project window, or 
- select the table's name and click the Open button. 

 
To open a theme's table: 

- Open the view containing the theme. 
- Click on the theme to make it active. 
- Click the Open Theme Table button in the View button bar. 

When you open a theme's table, it will appear in the list of tables in the Project window 
in which case it can also be opened using the Open button on the Project window, as 
described above. 

19. EDIT A TABLE 

- choose Start Editing from the Table menu.  
If you have write access to the data source, you will be allowed to edit the table. You 
can add or delete fields and records and edit the values in the table. See Overview of 
editing a table. 

PDF created with FinePrint pdfFactory trial version http://www.pdffactory.com

http://www.pdffactory.com


      21 21 
 

Close the table 
From the File menu, choose Close, or click the close control on the table's window. 

Rename the table 
Click once on the table in the list in the Project window and choose Rename from the 
Project menu.  

20. ADD A TABLE INTO A PROJECT 

- Use Add button in the Project window to open a dBASE, INFO or delimited text 
file as a table in your project. See Adding tabular data. 

To connect to a database to create a table use the SQL connect option in the Project 
menu. See Connecting to a database to create a table. 

Adding and deleting fields in a table 
To add a field to the table you are editing, choose Add Field from the Edit menu. 
When you add a field to a table a dialog appears that asks you to specify the new field's 
name, type and length.  

Field types 
You choose from four different field types: 

• Number: You can specify the width of the field in digits in the Width field, and the 
number of decimal places in the Decimal Places  field. Specifying 0 decimal 
places will make the field an integer. Note that the width includes a count for the 
decimal point and the negative sign (if applicable). 

• String: You can specify the width of the field in characters in the Width field. 
• Boolean: Each value in a Boolean field is either True or False. When you type 

values into a Boolean field you can either type True or False in full, or just type t 
or f which ArcView will immediately convert to True or False for you. 

• Date: Each value in a date field is eight digits in the format YYYYMMDD. For 
example, the 10th of February 1972 would be represented as 19720210. When 
you type dates into a date field they must be in this format. 

 
To delete a field:  

- click on its name in the table to make it active, then  
- choose Delete Field from the Edit menu. There is no "Undo" to this operation; 

once a field is deleted it is no longer accessible in the table. 
 
Tip: If you wish to hide a field rather than actually delete it,  

- choose Properties from the Table menu and uncheck the field's name in the 
Visible column. 

21.  DELETE A TABLE 

- Click once on the table in the list in the Project window and  

PDF created with FinePrint pdfFactory trial version http://www.pdffactory.com

http://www.pdffactory.com


      22 22 
 

- choose Delete from the Project menu. You will be prompted to confirm deleting 
the table. Deleting a table removes it from the project, but does not affect the 
tabular data source that the table is based on. 

22.  COPY A TABLE FROM ONE PROJECT TO ANOTHER 

If you want to get a table that is in another project and put it into your current project, 
you should import the other project into your current one using Import in the Project 
menu. This will copy all the components of the other project into your project. You can 
then delete the components that you don't require using Delete from the Project menu. 
See Importing other projects. 
 
Another way to copy a table from one project to another is to export the table to disk 
and then add it into your current project. The advantage of this is that it lets you control 
which records and fields in the table are transferred from one project to another, 
because Export exports the data in the table's selected records and visible fields. 

23.  LABELING FEATURES OF A THEME 

- From Theme Menu Click Auto Label  

 
- From the label field choose the field you want to display in the View (labels will 

appeared in the View) 

Remove Labels 
- From Theme Menu Click Remove Label (all labels for the theme will disappear) 
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24. LEGEND EDITING 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Set a classification 
1   Click the Classify button in ArcView’s legend editor. 
2   Choose a type of classification. 
3   Set the number of classifications. You may use the drop-down method or click on 

the value box and directly type in your number of classes.   
If you chose the Standard Deviations classification, set the Interval that will 
determine the class breaks. If you choose the Manual Equal Interval classification, 
set the minimum and maximum value for the data range. 

4   Choose the place at which your data values will be rounded. 
5   Click OK. 

25. CONVERT A THEME INTO A SHAPEFILE 

Why convert a theme to a shapefile? 
You want to edit the features in a theme but the Start Editing option in the Theme menu 
is dimmed out when the theme is active. This is because only themes based on 
ArcView shapefiles can be edited in ArcView. If you want to edit a theme that is based 
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on other feature data sources, such as ARC/INFO coverages, CAD drawings, 
etc. you should first convert the theme to a new shapefile and add it to your view.  
 
1 Click on the name of the theme you want to convert to make it active.  
2 Choose Convert to Shapefile from the Theme menu. 
3 In the dialog that appears, specify a name and location for the shapefile. 

Press OK 
4 You are prompted to see if you want to add the new shapefile to the view you 

are currently working on as a theme.  

26. MEASURE TOOL 

Use the Measure tool  to measure distance on a view.   
 
Use the mouse to draw a line defining the distance you want to measure. The 
measurements are displayed in the ArcView status bar, shown in the current 
distance units of the view. 
> If you are using global data in decimal degrees, and you've set your map and 

distance units, the Measure tool will return the shortest spherical distance 
between the two points you click.  

> If you click on Los Angeles, for example, and move the mouse toward Sydney, 
you'll see the Segment Length reported in the status bar go up, and then down 
as you move the mouse across the globe. When you click on Sydney, the 
number reported is the distance from Los Angeles to Sydney going the other 
way around the globe (the shortest distance). 

 
- Using shapes to make measurements 

When you use the Draw tool  to draw shapes on a view, the dimensions of 
the shapes are displayed in the status bar in the current distance units of the 
view. This is a useful way to make measurements because the distance or area 
you measure remains displayed on the view as a graphic shape, which you can 
then edit using the Pointer tool. If you change the shape or size of the graphic 
shape, its new dimensions are shown in the status bar. You can also change the 
parameters of a graphic shape using Size and Position in the Graphics menu.  
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27. SELF PRACTICE 1 

 
 
 
 
 
 
1- Create polygon shape file (Landuse) and digitize all Fields in the site.  

- Open it’s attribute table, and add 2 fields  
§ Land_use, 
§ Owner.  

 
- In the Land_us field, classify records as follow: 

   1 =  fields 
  2 = settlements 
  3 = Roads 
  4 = canals 
 

- In the Owner field, add names:  
Just like a,       b,  d, 

 
- Calculate the area for every Fields. 

 
- Classify theme legend by Land_use field  

 
- Label Fields by their Owner 
 
- Save your work 

 
 

2- Create line shape file (Canals) and digitize canals in the site.  
- Open it’s attribute table, and add 2 fields: 
§ Canal_Name 
§ Canal_Type 

 
- Classify by Canal_Type  
 
- Label canals by Name 
 
- And save the Project 

 
 
End 
 

Add (Zabid_8bit_3_1.img) Image and switch to the area located 
between:  

East   = 330,000 & 331,000 
  North = 1,568,200 & 1,569,000 
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28.  ADDING FILES CONTAINING TABULAR DATA TO YOUR PROJECT 

You can add dBase III or dBase IV file to your project as a table. 

To add an dBase file to your project 
- Make the Project window active. 
- From the Project menu, choose Add Table 

 
 

- From the File Type list, choose INFO, dBase (.dbf), or Delimited Text (.txt) 
- Navigate to the directory that contains the file you want to add. 
- Double-click the file you want to add or choose the file and press OK. 

(ArcView adds the table to your project.) 
 
NOTE:  Spaces, periods and other non-alphanumeric characters in file or directory 
names may cause problems. Spaces and underscores are the only non-alphanumeric 
characters that should be used. It is also recommended that you follow an 8.3 naming 
convention. 

Display the dBase Table in the View (Event Theme): 
- Click on the View to make active 
- From View Menu Click Add Event Theme (the add theme box will appear) 
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- From (Table) select your data table 
- In X-field select the x Axis 
- In Y-fields select the Y Axis 
- Click OK (New .dbf Theme will added to the View) 

 
Note: the Theme you just add is not a shape file and that means you can 
not edit it. To make it editable convert it to Shape file)  

Convert dB Theme into Shape file 
From Theme Menu Click on Convert To Shapefile 
In the box appear navigate to your folder and Type a name for the shapefile 
Click OK  
Another box will appear to ask if you want to add the new shape file to the view 
Click Yes 

29. CREATE LAYOUT AND PRINTING MAP 

Two ways to create a layout: 

Create a template 
- Click the View to make it active 
- From the View Menu Click Layout 
- Choose one from the Template Manager 
- Click OK  
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- From the View Layout Click New Layout 
- Click OK  

(New Layout will created) 

Create your own Layout  
- Click on Project window to make it active. 
- Click on the Layout Icon 
- In the Project window Click New (new empty Layout will added) 

Layout Page setup 
From Layout Menu Click Page Setup 
Set Page size to A3 and Orientation to landscape 
Click OK.  (This will set the print out to A3 size) 

Add your map to the Layout 
- Click on the View Frame 

 

 
- - Draw a rectangle on your Layout 
- - The View Frame Properties box will appear 

 
 
From View choose and Click on the name of your View  
Click OK and your map will be created in the Layout. 
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Add a North arrow 

- Click on the North arrow tool  
- In the layout click and draw a rectangle 
- Click OK and the north arrow will add to the Layout 

Add a legend  
 
- From tools click on the legend tool  
- In the layout click and draw a rectangle  
- In the box that appear click the name of the view 

 
 
- Click ok and the legend will be added to the layout 

Add a scale bar 
 
- From tools click on the Scale bar tool  
- In the layout click and draw a rectangle  
- In the box that appear click the name of the view 

 
- Click ok (the legend will be added to the layout) 
 
Note: by the same way you can add a table, chart or graphic as described above. 

Change the north arrow, legend, or scale  
- First click on the pointer to make it active 
- Click on the object you want resize 
- Pull the corners of the object 
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30. SELF PRACTICE 2 

- Extract locations of Gates from the following image, which distributed through the 
coordinates mentioned blow: 

  
 
 
 
 
 

- Create dB 4 table in excel with coordinates for those Gates 
 
- From ArcView add the dB table to your project 

 
-  Display the dB table on the view 

 
-  Convert the dB file shown on the View to Shape file? 

 
-  Activate all the Vector data you create (Land_Use and all other shape file)  

 
-  Create Layout for the View with north arrow, legend, scale 

 
-  Add grid to the View and setup the page to A3 

 
-  Print your map  

 
 
 
 

 (Zabid_8bit_3_1.img) Image and switch to the area located 
between:  

East   = 330,000 & 331,000 
  North = 1,568,200 & 1,569,000 
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31. DC WATER DESIGN 

What is the DC Water Design Extension? 
The DC Water Design Extension is an Extension to ESRI’s ArcView GIS software. It 
allows to store, edit, and retrieve EPANET hydraulic models including all options 

Install the DC Water Design 
- From Windows Start\ Run\ go to the DC Water Design folder and run setup and 

follow the instructions 

32. WORK WITH DC WATER DESIGN 

- Open ArcView  
- Click on Project with new View  (set the View Properties) 
- Add to View the images that you will extract their hydraulic model (load Image 

Extension if needed). 
In appendix A you can find a manual on DC Water written by Tom Chidley.  

Add DC Water Design Extension 
- Click File Menu >Extensions 
- Click check box of DC Water Design  

(the DC Water Design Menu, Buttons and Tools will be added to the UI) 
at the same time the following setup box will be created 
 

 
 
- Change the Snapping Radius value to 5 meter 
- Click OK  
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Create the DC Water Design Shape files 
Create four Shape files: 

1- Point Shape file with a name (canal_inlet.shp) 
2- Point Shape file with a name (junction.shp) 
3- Point Shape file with a name (offtake_structure.shp) 
4- Line Shape file with a name (conveyance.shp) 

 
Note: be sure if you decide to create another DC Water Design Project to give your 
Shape file different names or you will lose your data 

Setup the EPANET Themes 

- Click the Epanet Themes Button  
(The following box will appear) 

 
 

- Adjust your Themes as above 
- Click OK  

Create Missing Fields  
- From the DC Water Design Menu Click Create Missing Fields 
- Message box appear To inform you how many fields are created Click OK  

(The DC Water Design Tools  will activated) 

Add fields to the attribute table (Name and Type) 
Add 2 fields to the Pipe attribute table (name and type): 
During the digitizing you will add in the name fields the (canals name) and in the type 
field you will add canal type (main, secondary and tertiary). 
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Start digitizing 
- Go to upper area of the water flow 
- Zoom to 1000 m 

- Click on the Pipe Tool of DC Water Design   
- Start digitizing from the upper stream towards downstream till the end of the 

Wadi 
- Double Click to stop editing 

(This operation will adds 2 junction one at the start point and one at the end) 

Change the junction type 
Here you will change the start point into reservoir  

- Go back to the start point  
- Click on the Node Class tool 
- Click on the start point.  the following box will appear: 

 
 
 
 
 
 
 
 

- Select reservoir to change the type of the junction to reservoir 
- Click OK  

 
 
To add valves (gates): 
 

- Click on the Split Pipe tool  
- Click on the pipe close to the gate to split the pipe 
- Click on the Pipe tool and digitize a short distance till you reach the gate, double 

Click to stop Editing 
- Click on Node Class tool the above box will appear 
- Select valves 
- Click OK (this will change the junction to valve 

Check the EPANET Model 
- from DC Water Design click Check Epanet Model 
- a message box appear to inform you how many duplicate features you have in 

the Model and if you have any open the table and change the values to avoid 
duplicate and get a unique value 
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Delete feature 
- From the DC Water Design tools Click Delete feature  
- A box will appear to ask you which you want to delete pipe or Junction 
- Confirm Yes or No 

Move Junction 
- Click Move Node tool 

Reshape pipe 

- Click  

Check the EPANET Model 
- from the DC Water Design Menu Click Make Epanet Model 
- a box will appear to inform you how many of each 
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Appendix A Notes on DC Water from Tom Chidley 
 
I am preparing manuals for various functions. This one is for digitising Irrigation 
Schematics using DC Water ArcView Extension. You should also read the DC Water 
manual. A new version of DC Water with Arabic translation, examples, manuals etc. can 
be downloaded from http://dcwaterdesign.sourceforge.net  
I will add some graphics to illustrate some of the processes, if required. Please advice. 
 
DCWater Node-link Editor  
 
It is often useful to be able to prepare Node-Link diagrams that are editable and maintain 
the connectivity while editing. I have adapted an ArcView Extension called DCWater. 
This was built to prepare data for a pipe network analysis program called EPANET. A 
detailed manual for using DCWater exists and should be consulted before using the 
system. 
 
The EPANET model uses the following features: 

1. Pipes 
2. Junctions (of pipes) 
3. Valves 
4. Pumps 
5. Tanks 
6. Reservoirs 

 
For the purposes of modelling an irrigation system a mapping of the water distribution 
network is required. As follows: 

1. Pipes are mapped to irrigation water conveyances with the type: 
a. Wadis 
b. Ogmas 
c. Links 
d. Main canals 
e. Secondary (branch) canals 
f. Tertiary canals 
g. Field distribution systems 

2. Valves are mapped to control structures 
3. Reservoirs are mapped to inflows to wadi inflows 
4. Pumps or tanks could be modelled as wells if required 
5. Junctions (these may be given types corresponding to the types needed in the 

SMM model: 
a. Continuity junctions 
b. Demand nodes, delivering water to  a field irrigation system 

6. You must create new themes for pipes/water conveyances (as lines); 
valves/control structures (points); reservoirs/wadi inflows (points); and junctions 
(points). 

7. When the themes are created you must add fields for DCWater and SMM, see 
below. 

 
In order to operate the model you need to: 

1. Activate the DCWater Extension (after having installed it on your computer from 
the file in DCWater Extension 
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2. Two extra menu buttons, and two extra tools will be provided on the View 
Window tool bar areas. 

a. Dialog to inform DCWater which shape files contain junctions, pipes, 
valves and reservoirs (ignore other options) 
i. Junctions are mapped to junction theme 
ii. Pipes are mapped to the conveyance theme 
iii. Valves are mapped to the control structure theme 
iv. Reservoirs are mapped to wadi inflow theme 

b. Dialog to inform DCWater about certain tables, ignore 
c. Tool for adding junctions, reservoirs and pipes 
d. Tool for editing reservoirs, junctions and pipes 

i. Add a junction 
ii. Split a pipe 
iii. Change a junction type 
iv. Move a junction 
v. Flip flow direction 
vi. Erase 
vii. Edit vertices 

 
3. An extra menu appears on the View window menu bar and the Project Window 

Toolbar. 
a. The Menu on the Project window menu bar is used to 

configure DCWater, probably you only need to set the snap distance to 
about 4 to 6 metres if you are digitising at a scale of 1:1000. 

b. The menu on the View window  contains many options but you 
mainly need: 
i. Check Epanet model 
ii. Build Epanet model 

 
4. When creating a new system create new themes from the DC Water View menu 

for: 
a. Irrigation water conveyances 
b. Control structures 
c. Junctions 
d. Wadi inflows 

When the new themes have been created, you use Create missing fields from the 
DCWater menu to create all additional fields required by DCWater in the newly created 
themes. Later you may wish to assign aliases to the DCWater names and use them for 
SMM. 
 

5. Add further additional fields for use by SMM, initially type, name and code are 
needed 

6. If you have created a network of pipes/conveyances without nodes by digitising 
just a set of arcs, you may use the Create Missing Junctions form the DCWater 
menu to add junctions at ends of pipe/conveyance sections. If you do decide to 
create the line network first, make sure you set a suitable snapping distance for 
the theme form the ArcView Theme-Properties data entry sheet – the lines must 
be joined (snapped). 

7. The menu item Calculate pipe length for junctions can be used to compute 
lengths of segments of the canals/conveyances. 
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8. You use Check an Epanet model to eliminate duplicate node/pipe/reservoir 
identities (this means chaning node ID’s etc to make them unique) 

a. I propose using the notation jnn for junction numbers (letter ‘j’ 
and ‘nn’ as number) 

b. vnn for valves (control structures) 
c. rnn for reservoirs (wadi inflows) 
d. pnn for canals/conveyances/pipes 

9. If duplicate identifiers are found they are flagged, just open the attribute tables 
and edit the identifiers removing duplicates 

10. You use Build an Epanet model to resolve any network connectivity problems. 
a. The build will check if all links are connected to nodes of one 

type or another 
b. You may be warned that some links/pipes/channels are smaller 

than the snap distance. In this case you must temporarily reduce the snap 
distance form the project window menu. 

c. It also adds dummy node identifiers for ‘valves/control 
structures’ and ‘pumps’ because they are not actually points, they are 
system with both an inflow and an outflow point. 

11. If you right click over an object you can view or edit its attributes. 
12. You may add any extra fields to describe your own objects or provide parameters 
13. The network connectivity data will be used to construct SMM models (this is an 

important link to the SMM model and must be fully understood). 
14. When starting to create links and nodes from an empty theme you create a pipe 

(channel) after which DCWater will tell you that a pipe has been created with two 
new nodes, you accept this. 

15. You then add another pipe commencing at the end of the first pipe, if you are told 
that only one new node has been created accept it (if two new nodes have been 
connected the pipe has not been connected to the existing one do not accept it – 
you may increase the snap distance – note the snap distance should be 
consistent with the scale at which you are digitising) 

16. Once you have build a network of pipes/conveyances and junctions/control 
structures you may edit the attributes – in our case we assign nodes to a type 
(add a new field for this), you may also wish to change some nodes to another 
type. When you do this run the Check Epanet Model option and resolve any 
duplicate names. 

17. To install DCWater go to the Dcwatdes-2.07setup.exe program in the 
DCWater_2_07 directory and run it. There are manuals in this directory also. 
Version 2.08 is now available and includes an Arabic language interface. If you 
have already installed version 2.07, remove it before installing version 2.08. 
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APPENDIX B NOTES ON ARCVIEW TRAINING 

1. IMPORTANT DEFINITIONS 

1.1 GIS and Arcview 
GIS stands for Geographical Information System. GIS is a computer system that can hold and 
use data describing places on the Earth’s surface. GIS have three main elements: computer 
hardware, application software modules - e.g. Arcview – and data management and analysis 
procedures. GIS uses spatially referenced or geographical data and GIS carries out various 
management and analysis tasks on these data, including their input and output.  
 

1.2 Spatial data 
All GIS software has been designed to handle spatial data (also referred to as geographical 
data). Spatial data are characterized by information about position, connections with other 
features and details of non-spatial characteristics.  
For example, spatial data about Al-Arais weir may include: 

• Latitude and longitude as a geographical reference. This reference can be used to 
deduce relationships with nearby features of interest. If the latitude and longitude of a 
weir are known, the relative position of other weirs can be deduced. 

• Connection details such as which service roads and bridges to cross the wadi. 
• Non-spatial (or attribute) data, for instance details of the use of land or vegetation. 

 
Spatial data must be simplified before they can be stored in the computer. A common way of 
doing this is to break down all geographic features into three basic entity types. These are: 

• points 
• lines 
• areas 

An entity is a component or building block used to help data organization. In Arcview these 
entity types are shapefiles. 
 

1.3 Raster and vector data 
Points may be used to represent the location of features such as wells. Lines can be used to 
represent features such as canals, wadis and weirs. Area features are used to represent 
geographical zones (farmers plots).  
 
Points, lines and areas can all be used to represent surfaces that represent real-world 
phenomena. These representations are normally held in a GIS according to one of two models: 

• raster (sometimes referred to as grid) 
• vector 

 
These two different approaches are compared in figure 1. The raster model is particularly 
applicable where remotely sensed images are used and is considered the most appropriate 
choice for modeling continuous geographic phenomena such as snow depth. The vector model 
is more appropriate for mapping discrete geographic entities such as road and river networks 
and administrative boundaries.   
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2) Start a new project 
• When you have your own views which you would like to add to a project you can open a 

blanc document 
• Give a name to view 1 to 4: e.g. view 1 = data from Zabid; view 2 = data from Tuban, 

etc.  
• Different layers can be shown – without the image – from: “Start a new project” and 

select the project (extension .apr) 

3) Open an existing project 

• Click the Arcview icon  
• Select “open an existing project” and click OK 
• Select the drive in which the document is saved and select the file name 
• Select the file you want to work with and click “open”. 

4) Set view properties 
• Click View from the menu, select “Properties” 
• Click the map unit box and change to “meters” 
• Click the distance box and change to “meters” 
• Click OK 
• Give the view a name 

5) Add image to a view 
Add image extensions 

• Click from File menu “Extensions”  
• Check the boxes, which support the images to add them (clicking all the boxes will 

simply slow down the programme).  
• Thus, select the “IMAGINE Image Support, JPEG, NITF, MrSID, TIFF” 
• Click OK 

 
Add images 

• From View menu click “Add theme” or use the button  
• Change “data source type” to extension: .img (the extension: .rrd = supporting 

information for the image) 
• When you want to select more than one image press “shift” and click on the second 

(third, fourth, etc.) file 
• click OK 

 
Note: In Tuban images are displayed in extension .tif 

- You can display an images by clicking on it to be activated (or to be shown on 
screen)   

6) Save project 
• via File from menu 
• Save project in the correct drive and name it 
• the extension will become .apr 
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• notice that in Arcview a project is presented in one file while in Explorer this same file 
can contain many (e.g. 5) subfiles, which are small (mostly 1 Kb), besides the (larger) 
project file itself 

• Therefore, do not copy, delete or rename a file in Explorer which is created in Arcview 
• If you want to delete, copy or rename a file then select from the File menu “Manage data 

source” 
• You cannot delete, copy or rename an active file 

7) View 
Create new view 

• From View menu click “New” 
• set the properties for this newly created view 
• Activate your views by clicking on them (or with shift and click on another view by 

selecting two or more at the same time) 

8) Zoom 

• you can zoom in with the button  and select with a square the area to be zoomed 

• you can zoom out with the button   
• or you can change the scale into e.g. 1:2000 

• “zoom to active theme” with the button  The whole image of one layer will be shown 

• “zoom to full extent” with button . All layers will be shown 
 

9) Shapefiles 
Satellite images can be seen as the first layer of your project. A shape file is the second layer of 
your project, which contains your work on the satellite images. For example: digitizing plots, 
locating wells, roads, bridges, etc. can be done by creating shapefiles.  
 
Create a new shapefile 

• From View menu click “New theme” or “Add new theme” 
• When you want to digitize plots, use “polygon”; when you want to digitize pipes, use 

“line”; when you want to digitize wells, use “point”. Note: with polygons you cannot create 
lines or points, etc. Therefore, you will have to create a new shape file 

• click OK 
• the new theme will be opened. Navigate to your folder and type the name of your shape 

file (or theme) in the “File name” 
• click OK and now your new theme will be added to View 

 

10) Set theme properties and Snap 
Before you start digitizing you will have to set the theme properties (snap). The polygons you 
are going to create by digitizing them are named “features”. 

• From Theme menu click “Properties” 
• Click the “Editing” icon from the left row 
• Click the “General” check box and set the tolerance value, e.g. 3 m 
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• Click the “Interactive” check box and set the tolerance value, e.g. 3 m. These values 
allow you to work precisely or less precisely (in case you fill in a high tolerance value) 

• press OK 
 
General snapping  going from feature to feature automatically (mostly used in digitizing) 

Interactive snapping  allows you more control over how your features get snapped, thus this 
is more precisely. 

11) Digitizing 
Before you start 

• before you can start digitizing, activate the theme by clicking on the View 
• then go to “Theme” and “Start editing”;  

• choose the snapping environment with the button  and select the shape you want to 
use for digitizing 

• The first plot to be digitized should be selected with the button   
• Adjust the scale to be 1 to 2000 if your are going to digitize plots to make sure you are 

digitizing correctly on the lines  
• Adjust the scale to 1:1000 when you are going to digitize canals and wadis, etc.  

 
Forgot to select “Start editing” 

• If you did not select “Start editing” before you start digitizing then you will notice that your 
digitized work is not added to the shape file but remains like a graphic.  

• Graphic data cannot be transformed into a table as where data created in a shape file 
can.  

• You can make sure that you have selected “start editing” when via the Theme menu 
“stop editing” can be activated. 

ð If you accidentally did not activate “start editing” before digitizing and you 
are thus making graphics instead of shape files you can copy your 
graphic by selecting from the Edit menu “copy” and “paste” your graphics 
into the shape file. 

  
Digitizing of the first plot 

• The best way to digitize is from a single plot to a group of plots  
• start digitizing the first plot by clicking the left mouse button where you want to start your 

polygon and double click the final point. 
Digitizing the second and following plots 

• All the following – adjacent – polygons should be digitized selecting the icon  
• click therefore inside a digitized polygon to start and to end 
• if you would click on the border you might find that the polygons are not connected, 

which you do not want.  
• Every polygon should be connected to another polygon to avoid having gaps. This is to 

be to be able to classify all the area; 
• Note that lines should never be closed. 

 
Modifying of the shape of a digitized polygon 

• click the vertex icon  and click the polygon-line you want to modify 
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• now you can reshape the polygon by moving the line in any direction 
• If you want to reshape an overlapping line then click the line twice 

  
Splitting of a digitized polygon 

• select the icon to split two polygons 
• Start the splitting with clicking outside the polygon you want to split and end also outside 

the polygon (like cutting cheese...) 
 
Merging of two digitized polygons 

• click the pointer icon  and click the first polygon you want merge onto the second 
polygon (with help of shift you select the second polygon) 

• select from the Edit menu “Union feature” 
 
Cutting of overlap of two digitized polygons 

      
 

• select with the pointer the 2 plots (use shift) 
• go to Edit in the menu and “Substract features” 
• the overlap is then cut like this 

 
 

Or...if you want the overlap to be cut in this way: 

       
 

• select with the pointer the 2 plots 
• Go to Edit in the menu and press shift while at the same time you select “Substract 

features” 
 
Digitize a plot on the border of your view 

• while you are digitizing click the right mouse button and select “Pan” 
• now you can move the image without losing the digitized polygon you were working on 

at that moment 

• when you would use the  icon than you would loose this last digitized polygon 
 
Deleting last digitized point of a polygon 

• click right mouse button and select “delete last point” 
• in this way you will not loose the whole digitized polygon 
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12) Text 
• text can only be in graphic (not in a shape file) 
• Add text to an attribute by clicking the text icon   
• Changing of font and color of the text is mumkin by selecting the text with help of the 

pointer icon and then go to “Windows”, “Show symbol window”  
• select “Text” with help of the button  
• (Re)Moving of the text is possible by clicking on the text with help of the pointer icon. 

13) Edit shape file 
• click the project (*.apr) 
• click table  
• click new 
• navigate to your directory 
• give the file a name, e.g. Zabid_data, click OK 
• now you have created a frame for a database (Zabid_data.dbf) and you can add new 

fields 

14) Add new fields and data records 
Fields are columns, rows is a data record 
• go to field, “Start editing” 
• go to Edit menu, “Add field” (the attribute table should be active) 
• give field definition a name 
• select the type:  

- string = when the data is text and no’s 
- boolean = when the data depends on yes/no 
- date = text 
- number = when the data are only numbers 

• if you have no’s + text: select the string-type; when the new fields are containing 
(farmers’) names then select the string type 

• Now you have created one field for the choosen type 
• Go to the Edit menu, “Add record” (records are added as a row) 
• [under type there are zero’s, which you fill in later] 

15) Add the data 

• click the edit icon and click on the table to be edited  
• edit the table 
• when you are finished: go to Table menu and “Stop editing” 
• automatically will appear the question: “save the table” 
• click OK 

All tables appear with the extension *.dbf 
 

16) Loading of a table in your project 
You can load any table in your project – also tables created in other project or other programs.  

• Press the table icon in the left column of your project (*.apr) and click “Add” 
• Navigate for the directory of your table 
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• at any time you can add records and fields 

17) Calculate the area  
• Load the Xtools: go to File menu, “Extensions” 
• check the Xtools 6/1/01 box 
• click OK 

In the menu bar of Arcview now Xtools has appeared. From the Xtools menu you can select 
“Calculate Area/Perimeter/........” 

• select the shapefile you want to calculate the area for 
• click OK 
• the calculation of the area is done automatically 
• click the shapefile you calculated the areas for en then click the icon “Add theme table” 

 
Your attribute table for area will appear in the background (click on it to make it to be activated) 

• you can select a field in the view which is then at the same time selected in the table 
• click the icon “select feature” and then click in the view the plot you want to see the 

area for => the data for this field is given in a yellow color 
• you can also calculate all the areas by clicking the icon “Select all” 
• you can calculate the area quickly by making a square with the pointer icon. This is no 

precise way of calculating a plot but will give you an idea. 
 
If you would like to calculate the total area of owner “A”: 

• click the icon “Query builder”  
• double click in the table “fields” [owner] 
• click the   =   button 
• click the name of the owner 
• click new set 
• choose “Statistics” from Field menu 
=> here you will find the sum of the area 
=>  These statistics data can be saved in a database table by: 
• Xtools menu, select “Table statistics” 
• give the table a name and click OK 
• now you’ll find these same statistics in a table 

18) Measurement of distances  
You can only measure distances directly on the screen but the data will not be saved 

• fix a start point (A) with a dot on the screen and fix the end point (B) 
• click the “measure” tool icon  
• digitize the distance (according to a line) to be measured from A to B 
• the length can now be read on the bottom of the screen. Notice that if your scale is large, 

your measurement shall be less precisely 
 

19) Labeling features  
With a label you can add data to the attribute table, e.g. “area”. This label can be shown directly 
on screen: e.g. name of the owners, name of canals, etc. 
To add a label 
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• click the Theme menu and “Auto-label” 

• when you select “none” (with the icon ) then a label for all data is processed 

20) Changing the font 
• Go to the Window menu and select “Show Symbol Window” 
• Make your changes/selection as a default with the icon  
• Click the ABC-icon  

 

21) Changing of the legend 
Before you can change the legend you will have to stop editing and safe your work. 

• Click on the shapefile legend 
• select from here Legend type   
• Classification field   
• By default you’ll get five classes but these can be modified according to your 

preferences by “classify”, “number of class” and click OK 
• To change the color click on the color of your legend 
• you can change the background into transparent and the foreground into a color or 

hadging 
• save your legend and set it as a default 

22) Convert excel data to be imported in Arcview 

E.G. LANDMARKS TAKEN WITH THE GPS 

1) Prepare the table in excel.  
No. Name X (East coordinate) Y (North coordinate) 
LM 40 Munasirah  495370 1439759 
LM 41 Ober Safi 497267 1439774 
LM 42 Ober Riaad 498714 1439966 
Table 1: example for linking GPS data into Arcview. 
 

• you prepare a table with only columns and rows, without merging the cells 
• no head title is needed because but you need to put a description above your data as 

shown in table 1. 
2) In excel: “Save as type” *.dbf [dbase 4] (DBF IV). If you have problems saving the list then 
first select the whole table and save the document (as dbase). 
 
3) To open the dbf-file in Arcview 

• Click on the “Project” (*.apr) 
• click the table icon from the left column 
• click “Add” and browse to your drive, directory and file name 
• select your table from the list and click OK 

 
4) click on “View”  

• From the View menu “Add event theme” 
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• Table: select the name of your table   
• Xfield: Easting 
• Yfield: Northing 
• click OK 
• make the view active, click the database check box; your data from the table will now 

appear in the view 
 
Note: you have created a database file which you cannot edit. Therefore, you will have to 
convert the .dbf into a .shp (database file into a shapefile). When doing this, the LM points taken 
become points. 
 
5) Convert *.dbf file into *.shp file  

• go to Theme menu and “Convert to shapefile” 
• browse for the correct drive directory and give a file name 
• the question: “Add shapefile to view” appears and confirm with Yes 
• now the extension of your database file is converted into a shapefile (*.shp) 
• click OK 

23) Create a layout 
There are two methods to create a layout: 

1) Click on View menu, “Layout” 
• select “Landscape, Portrait”, etc. 
• click OK and a preview of your print is shown 
• you can modify the data (further explained in the second method) 

 
2) Click on project window to make it active (*.apr) 
• click the layout icon 
• click new (layout 1 will be opened) 
• select from Layout menu, “Page setup” 
• select the paper size 
• units: cm’s and click OK 
=> Transfer the view to layout 1 (this is what you see on screen) 
• “View frame” icon   
• Your mouse pointer becomes a cross => draw a rectangular in layout 1 
• click the correct view to be printed and click OK 
• the scale is automatically set but you can modify this: to change the scale go to  scale: 

“user specified scale”, change the scale, e.g. 1:3000 and click OK 
• On layout 1 now appears a preview 
=> In case you are not happy with the layout it’s best to delete it and prepare another layout. 
Select herefore the pointer icon and select then your layout with the pointer and press 
“Delete” 

24) Add a scale bar 

• Click the icon scale bar from tools   “Scale bar frame” 
• click on your layout 1 and move your mouse like making a square 
• the table scale bar properties will automatically appear 
• modify (with the pointer) to replace the scale bar 
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25) Add a legend  

• select from Tools the “Legend frame” icon   
• select the viewframe 
• the legend from the view (the shapefiles) appear as a legend 
• if you don’t want a certain legend item, press the right mouse button and select “simplify” 
• move the legend with the arrows or with the left mouse button 

26) Add a title and layout of the title 

• click the text icon  
• click in your layout 1, Insert a text for your view 

• from the   icon you can underline your title 
• from the “Neatline” icon you can make a frame over your text (outstide your view) 
• the line of this frame can be changed into a double line by clicking the right mouse 

button and “select all” then click the Neatline icon and select a linetype 
• click OK 

27) Add a north arrow  

• click the North arrow icon  
• click a rectangle in the layout 
• different types of north arrows appear 
• select one and click OK 

 

28) Add grids 
• From File menu you have to add the grid extensions 
• Click the check box Graticules and Measured Grids  
• click OK 

• the blue Graticule and Grid icon appear in your Arcview programme  
• activate your layout 1 
• click the icon  
• choose the view frame 
• click the check box Create measured grid  
• click next 
• enter a grid interval (this is filled in automatically but you can adjust to your liking, 

depending on the scale) 
- tic marks are   
- lines are      

• click next  
• click finish and you’ll get the preview 
• if you want to change anything click “remove” (e.g. “align table to border” which will give 

numbers parallel to the border of the view) 

29) Notes on DC Water 
 
With DC Water you can make hydraulic designs for water supply 
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When loading DC Water four icons are added to your Arcview programme: 

- Epanet Theme   
- Epanet tables   
- Flip  
- Junction   

 
Ad “Add DC Water Extensions” it is important to look at the snap radius 

• click the project window, DC Water Design menu and select “Setup” 
• select a number between four and ten meter 
• sometimes you’ll need to put a number lower than four (but then a automatic message 

will appear). 

Linking of shapefiles 

• Shapefiles can be linked with the icon   
• “Epanet Theme” appears => click the check boxes 
• the main setup is always like it is shown in the table “Epanet theme” 
• After this step you go to DC Water Design menu and “Create missing links” 

- then the two icons  and are activated 
• In the attribute table of the different shapefiles the fields are added automatically 

Set view properties 
Without setting these properties the scale shall not appear 

• fill in [m] and [m] 

Start digitizing 
• select from the DC Water menu, “Make Epanet model” to check whether you have 

started your work correctly. This means that everything should be numbered with a zero 
(0) 

• change the scale into 1:1000  
• start always from the reservoir (which is considered as the supply system) 
• to finish digitizing: double click your last point 
• four shapefiles are connected with each other and appear as one model 
• with the icon “node class” you can change e.g. reservoirs into valves or the other way 

around 
 
In the attribute table of e.g. pipe.shp you will have to add two fields: 

1) for naming 
2) for the type (canal, valve, etc.) 

Finish digitizing 
• Click from DC Water menu, “Check Epanet Model” to check whether there are no 

duplicates 
• if there are then check the attribute table (zoom to selected) and rename one of the 

duplicates 
• in the attribute table you can give names and define types 
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